Лабораторна 1. Хешування
Налаштуйте Файловий провідник таким чином щоб відображалися розширення імен файлів та приховані файли через меню Вигляд.
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Завантажте з архів образу досліджуваного диска Vader_Home_Computer.zip (https://drive.google.com/file/d/1ptqbPdTLPGvQ6WzT22AJtobVGkECqdO9) 
Дуже великий файл – 10ГБт. Плануйте його завантаження завчасно!
Разархівуйте його. Vader_Home_Computer.001, Vader_Home_Computer.002 … Vader_Home_Computer.005.
Встановіть та відкрийте FTK Imager (https://www.exterro.com/digital-forensics-software/ftk-imager)
[bookmark: _Hlk199776071]Виберіть File > Add Evidence Item > Image File > Browse > Vader_Home_Computer.001 > Finish.
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Перейдіть до папки C:\Users\Owner\Documents\Secret pics.
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Експортуйте папку «Secret Pics» на локальний жорсткий диск за допомогою контекстного пункту Export Files контекстного меню (натисніть правою кнопкою миші на ній).
Перегляньте на комп’ютері три зображення в папці Secret pics використовуючи Windows, натисніть правою кнопкою миші три надані зображення відкрийте Властивості та запишіть розмір кожного файлу.
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me & the guys1.jpg розмір: ___________
me & the guys2.jpg розмір: ___________
me & the guys3.jpg розмір: ___________
Відкрийте кожне зображення та опишіть вміст. 
me & the guys1.jpg Опис: ______________________
me & the guys2.jpg Опис: ______________________
me & the guys3.jpg Опис: ______________________
Чи всі малюнки однакові?
Встановіть HashMyFiles (https://www.nirsoft.net/utils/hash_my_files.html).
Використовуйте HashMyFiles, щоб обчислити хеші всіх 3 файлів. 
Файл > Додати файли. Додайте всі три файли.
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Запишіть хеш-значення MD5 для кожного файлу.
me & the guys1.jpg Хеш MD5: ______________________
me & the guys2.jpg Хеш MD5: ______________________
me & the guys3.jpg Хеш MD5: ______________________
Встановіть HxD Hex Editor (https://mh-nexus.de/en/hxd/) на свій комп’ютер і відкрийте його.
У HxD виберіть Файл > Відкрити. Відкрийте один із 2 дублікатів файлів. Ви знаєте, що вони є дублювати, оскільки вони мають ідентичний хеш.
Перейдіть у нижню частину файлу та змініть останні декілька символів.
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Виберіть Файл > Зберегти як» і збережіть це зображення під іншою назвою.
Використовуйте Windows, щоб записати розмір файлу та хеш-розрахунок для хешу MD5 нового файлу.
Новий файл:
Опис: ______________________
[bookmark: _Hlk199844105]Розмір: ______________________
Хеш MD5: ______________________
Виходячи з результатів цього тесту, що ви думаєте про надійність MD5 як «цифрового відбитку»?
Використовуйте HxD, щоб перевірити останні декілька байтів кожного з наданих файлів і запишіть все, що може викликати підозру.
Виходячи з вашої відповіді на попереднє запитання, чи вважаєте ви, що злочинці можуть приховати інформацію у файлі jpg?
________________________________

Лабораторна 2. Дамп ОЗП та образ носія.
Помістіть виконуваний файл DumpIt (https://www.magnetforensics.com/resources/magnet-dumpit-for-windows/) у каталог, який слугуватиме місцем зберігання для оперативної пам'яті. 
*Примітка: зазвичай це розташування буде зовнішнім пристроєм, оскільки ви ніколи не бажайте писати на диск доказів. Однак для цілей цієї лабораторії не соромтеся для зберігання енергонезалежної пам'яті на ваш диск.
Двічі натисніть DumpIt і дайте відповідь на запитання програми.
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Розмір створеного дампу: ______________________
Візьміть невеликий USB-накопичувач або MicroSD картку (бажано менше 8 ГБ, чим більше, тим більше триватиме процес) і вставте його в комп’ютер.
Скопіюйте папку з файлами на ваш вибір на зовнішній накопичувач.
Відкрийте FTK Imager.
Виберіть File > Create Disk Image, виберіть Physical Drive і натисніть Далі.
Виберіть фізичний пристрій, який представляє ваш зовнішній накопичувач. (Імовірно \\.\PHYSICALDRIVE1). Натисніть Finish.
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Під полем призначення образу Image Destination(s) натисніть кнопку Add.
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Виберіть Raw (dd) і натисніть Далі.
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Додайте інформацію про справу за власним вибором.
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Виберіть папку призначення для криміналістичного образу та дайте йому назву файлу.
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Натисніть Finish.
Зніміть позначку з пункту Перевіряти зображення після їх створення (Verify images after they are created). У реальній справі це гарна ідея, але це збільшить час, необхідний для виконання цієї лабораторної.
Після завершення криміналістичного зображення натисніть Image Summary. Запишіть наступну інформацію:
Хеш MD5: ____________________
Розмір вихідних даних (Source data size): _________________
Кількість секторів (Sector count): ____________________
Виберіть File > Add Evidence Item > Image File > Далі.
Перейдіть до файлу криміналістичного зображення. Якщо він багатосегментний, виберіть лише перший (.001).
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Перегляньте структуру папок зображення, зверніть увагу на файли, які ви зберегли туди раніше.
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[bookmark: _Hlk199856984]Лабораторна 3. Відновлення файлів
Завантажте архів образу підозрілого зовнішнього накопичувача
Suspect_MicroSD.zip (https://drive.google.com/file/d/1g2TAl1BecvndsuezcnGhckbQ0kYZ2hdC). Розархівуйте його.
[bookmark: _Hlk199847549]Відкрийте FTK Imager.
Виберіть File > Image Mounting
Додайте файл образу Suspect_MicroSD.001, не змінюйте параметри за замовчуванням і натисніть Mount.
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Перейдіть до Провідника Windows і відкрийте диск «E:».
*ПРИМІТКА: Скоріш за все у вас це буде «E:», але може бути й інший диск
Це змонтована версія образу MicroSD картки підозрюваного. Зверніть увагу на файли, які зараз знаходяться у образі.
В FTK Imager виберіть монтовані диски та натисніть Unmount.
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Натисніть Close.
Відкрийте шістнадцятковий редактор «HxD».
Виберіть Інструменти > Відкрити образ диска та Suspect_MicroSD.001.
Здійсніть пошук за запитом txt Пошук > Знайти або Ctrl + F 
Пошук вниз – F3, пошук вверх – Shift + F3.
Потім за запитом omb.
Або відразу перейдіть до сектора 16384. Це початок таблиці розміщення файлів (FAT). Вона зберігає метадані файлу, такі як розмір, час створення, час зміни та ім'я файлу, а також фізичне розташування файлу на диску.
В секторі 16384 ви побачите назву файлу, який починається з шістнадцяткового символу E5 (сигма). Це позначає видалений файл. У файловій системі FAT перший символ видаленого файлу замінюється на шістнадцятковий E5 (сигма), а розташування файлу обнуляється, таким чином позначаючи його як доступний.
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Виберіть символ E5 та замініть його на B.
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Виберіть Файл > Зберегти як та збережіть цей файл під назвою Recovered_Suspect_MicroSD.001.
Поверніться до FTK Imager, скористайтеся утилітою монтування, щоб змонтувати Recovered_Suspect_MicroSD.001 так само, як ви змонтували оригінальний образ.
Відкрийте змонтований диск у Файловому провіднику Windows. Зверніть увагу на файли, які тепер знаходяться на образі.
[bookmark: _Hlk199863053]*ПРИМІТКА: Новий файл «bomb.txt» тепер видно з усіма його метаданими (відкрийте властивості файлу через контекстне меню). Однак фізичне розташування файлу все ще обнулено в таблиці FAT. Тому ми не зможемо фактично відкрити цей файл.
Поверніться до FTK Imager знову відмонтуйте диск та закрийте монтування образу.
Виберіть File > Add Evidence Item.
Виберіть Image File та перейдіть до файлу Suspect_MicroSD.001 і натисніть Finish.
FTK imager автоматично відновлює розташування видаленого файлу та відображає його. Знайдіть вміст образу в кореневій папці.
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Бомба знаходиться:________________
Вибух станеться:_______________
Автор листа:_______________
Встановіть та відкрийте Autopsy (https://www.autopsy.com/download/)
[image: ]
Введіть назву справи (Case Name:) та через Brows вкажіть папку, де будуть зберігатися файли справи. Next
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Введіть свою інформацію.
[image: ]
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Disk Image or VM File
Browse та вкажіть файл образу Suspect_MicroSD.001.
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Для економії часу аналізу виберіть тільки той модуль, що на малюнку. 
Залиште лише: Recent Activity
Також зверніть увагу, що вибрано All Files and Directories (Not Unallocated Space)
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Finish
Подивиться видалені файли.
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Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки?
_____________

Лабораторна 4. Аналіз основних артефактів Windows 10
Відкрийте програму FTK imager.
Додайте підозріле зображення (Vader_Home_Computer.001) до програми FTK imager.
File > Add Evidence Item > Image File та Далі > Browse та вибрати файл образу, вибрати Vader_Home_Computer.001 та відкрити > Finish.
Натисніть кнопки + для навігації по образу.
Перейдіть до кореневого каталогу Розділу 2 (root Partition 2).
Перейдіть до папки \Users\Owner\Documents\
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Які файли можуть свідчити про злочинну діяльність?
__________________________________________
Що це за злочинна діяльність?
__________________________________________
Перейдіть до папки \Users\Owner\AppData\Local\Microsoft\Windows\Explorer\
Експортуйте її на ваш комп’ютер.
Завантажте та запустить Thumbcache Viewer (https://thumbcacheviewer.github.io/)
Відкрийте завантажені файли в Thumbcache Viewer 
File > Open > Папка на вашому комп’ютері, де ви зберегли Explorer > thumbcache_768.db 
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Чим можуть допомогти в розслідуванні файли мініатюр (thumbcache_*.db)? Чому?
______________________________________
Відкрийте Autopsy.
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Відкрийте справу, що ви відкрили у попередніх лабораторних – Open Recent Case
[bookmark: _Hlk200556598]Додайте нове джерело – Add Data Source
Вкажіть шлях до Vader_Home_Computer.001
Для економії часу аналізу виберіть тільки той модуль, що на малюнку. 
Залиште лише: Recent Activity
Також зверніть увагу, що вибрано All Files and Directories (Not Unallocated Space)
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Finish
Дочекайтеся завершення аналізу!
Це може зайняти значний час.
Tools > Options > View > When displaying times > Use another time zone > (GTM+2:00) Europe/Kyiv
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Перейдіть Data Sources > Vader_Home_Computer.001 > vol3 > \Users\Owner\Documents\
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Передивіться документи.
Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки?
_____________
Перейдіть \Users\Owner\Documents\Busines\ та перемкніть вкладку на Thumbnail
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Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки?
_____________

Лабораторна 5. Аналіз кошику
Відкрийте програму FTK imager.
Додайте підозріле зображення (Vader_Home_Computer.001) до програми FTK imager.
File > Add Evidence Item > Image File та Далі > Browse та вибрати файл образу, вибрати Vader_Home_Computer.001 та відкрити > Finish.
Натисніть кнопки + для навігації по зображенню.
Перейдіть до кореневого каталогу Розділу 2 (root Partition 2).
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Яка назва та файлова система цього розділу?
________________________________________________________
[bookmark: _Hlk200443675]Перейдіть до папки $Recycle.Bin
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Його підкаталоги – це довге число.
Що це за число?
_________________________________________________
Перегляньте всі файли з каталогу S-1-5-21-383237201-15008683-2568520922-1002. Чи є якісь із них ознаки потенційних злочинних планів? Який саме? Які були плани?
_________________________________________________________
Які були шляхи до файлів, ім'я, розмір і дата видалення підозрілих файлів?
_________________________________________________________
Відкрийте Autopsy.
Відкрийте справу, що ви завели у попередніх лабораторних – Open Recent Case
Перейдіть Data Artifacts > Recycle Bin
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Через контекстне меню виберіть для знайдених файлів View Downloaded File in Directory, щоб подивитися їх. Повернення назад за допомогою стрілки у лівому верхньому куті.
Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки?
_____________

Лабораторна 6. Аналіз посилань на недавно відкриті файли (Recent) та файлів попереднього завантаження (Prefetch)
Відкрийте FTK imager
Відкрийте підозрілий образ (Vader_Home_Computer.001) у FTK imager.
Перейдіть до Users\Owner\AppData\Roaming\Microsoft\Windows\Recent\
Перегляньте файл Death_star1.lnk у шістнадцятковому вікні перегляду у FTK Imager? Яку інформацію ви можете розшифрувати?
________________________________________________________
Експортуйте всі файли з папки Recent до нового каталогу на вашому комп’ютері, назвіть папку Recent.
Встановіть / відкрийте RecentFileView від Nirsoft. (https://www.nirsoft.net/utils/recent_files_view.html)
[bookmark: _Hlk199928550]RecentFileView потрібно запускати від імені Адміністратора (в контекстному меню – Запустити з правами адміністратора)!
За замовчуванням RecentFileView аналізує файли на головному комп'ютері. 
У Options > Advanced Options у полі Load from виберіть External Source.
У полі Recent Folder вкажіть шлях до каталогу, куди ви експортували файли з папки Recent.
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Виходячи з назв файлів, чи може якийсь із цих файлів свідчити про незаконну діяльність? Які їхні назви та коли вони були відкриті востаннє?
_____________________________________________________________
Зверніть увагу на різні типи інформації, записаної у файлах посилань. Чи бачите ви аномалію у повідомленому шляху для файлів посилань? 
**Це пояснюється тим, що Windows бачить файли посилань, інтегруючи їх у локальну систему.
_____________________
Якщо ваш підозрюваний стверджує, що він не знав, що компрометуючий файл був у його системі, і він ніколи його не відкривав. Як ви можете відреагувати, виходячи з доказів файлу посилань?
_______________________
Один з компрометуючих файлів – це zip-файл. Використовуйте FTK Imager, щоб перейти до шляху, де цей zip-файл знаходиться на підозрілому зображенні. Які файли містяться в zip-файлі?
______________________________
Припустимо, що один з компрометуючих файлів виявився зашифрованим, і вам потрібен був пароль, щоб відкрити його. Чи вказують файли посилань на будь-які файли, які можуть містити пароль?
Де він знаходився і як ви могли б знайти цей файл?
______________________________
Відкрийте Autopsy.
Відкрийте справу, що ви завели у попередніх лабораторних – Open Recent Case
Перейдіть Data Artifacts > Recent Documents
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Через контекстне меню виберіть для знайдених файлів View Downloaded File in Directory, щоб подивитися їх. Повернення назад за допомогою стрілки у лівому верхньому куті.
Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки?
_____________
Відкрийте FTK Imager
Змонтуйте підозрілий образ (Vader_Home_Computer.001) до локального диска.
Використовуйте WinPrefetchView (https://www.nirsoft.net/utils/win_prefetch_view.html) для аналізу файлів попередньої вибірки підозрілої системи.
WinPrefetchView потрібно запускати від імені Адміністратора (в контекстному меню – Запустити з правами адміністратора)!
За замовчуванням WinPrefetchView аналізує файли попередньої вибірки на головному комп'ютері.
У Options > Advanced Options виберіть параметри та вкажіть шлях до файлів Prefetch змонтованого образу (F:\Windows\Prefetch).
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Які програми найчастіше виконувалися на підозрілому комп'ютері?
(Можна відсортувати по стовпцю Run Counter) 
___________________________
Коли WINRAR.EXE востаннє виконувався на цій системі? Чи є якісь вказівки щодо того, які файли відкривався за допомогою WinRar?
(Подивиться нижнє вікно WinPrefetchView, там вказані файли, з якими взаємодіяв програма, що виділена у верхньому вікні) 
_______________________________________
Коли Блокнот (Notepad.exe) запускався вперше та востаннє на цій системі?
(Стовпець Last Run Time)
_______________________
Чи є якісь вказівки щодо того, які файли міг відкриватися за допомогою Блокноту? 
________________________
Перед закриттям FTK Imager відмонтуйте всі змонтовані диски.

Лабораторна 7. Аналіз сигнатур файлів
Відкрийте FTK Imager 
Відкрийте підозрілий образ (Vader_Home_Computer.001) у FTK imager.
Перейдіть до папки C:\Users\Owner\Documents\Business\Secret Files.
Експортуйте папку Secret Files на локальний жорсткий диск.
Відкрийте HxD та використовуйте його, щоб відкрити кожен секретний файл у шістнадцятковому вигляді.
Перевірте початкові байти на початку кожного файлу, щоб визначити підписи файлів. Використовуйте Вікіпедію https://uk.wikipedia.org/wiki/Сигнатура_файлу_(перелік) як орієнтир.
В деяких випадках потрібно звернутися до https://en.wikipedia.org/wiki/List_of_file_signatures
В деяких випадках потрібно аналізувати не перші 4 байти, а менше.
[image: ]
Запишіть наступне для кожного файлу.
Ім’я файлу: file1
Перші 4 байти: ___ ___ ___ ___
Тип/розширення файлу: ____
Перейменуйте файл, додавши правильне розширення, та відкрийте його. Опишіть його.________________________
Ім'я файлу: file2
Перші 4 байти: ___ ___ ___ ___
Тип/розширення файлу: ____
Перейменуйте файл з правильним розширенням та відкрийте його. Опишіть його.________________________
Ім'я файлу: file3
Перші 4 байти: ___ ___ ___ ___
Тип/розширення файлу: ____
Перейменуйте файл з правильним розширенням та відкрийте його. Опишіть його.________________________
Ім'я файлу: file4
Перші 4 байти: ___ ___ ___ ___
Тип/розширення файлу: ____
Перейменуйте файл з правильним розширенням та відкрийте його. Опишіть його.________________________
Ім'я файлу: file5
Перші 4 байти: ___ ___ ___ ___
Тип/розширення файлу: ____
Перейменуйте файл з правильним розширенням та відкрийте його. Опишіть його.________________________
Ім'я файлу: file6
Перші 4 байти: ___ ___ ___ ___
Тип/розширення файлу: ____
Перейменуйте файл, додавши йому правильне розширення, та відкрийте його. Опишіть його.________________________
Ім'я файлу: file7
Перші 4 байти: ___ ___ ___ ___
Тип/розширення файлу: ____
Перейменуйте файл, додавши правильне розширення, та відкрийте його. Опишіть його.________________________
Ім'я файлу: file8
Перші 4 байти: ___ ___ ___ ___
Тип/розширення файлу: ____
Перейменуйте файл, додавши правильне розширення, та відкрийте його. Опишіть його.________________________
Ім'я файлу: file9
Перші 4 байти: ___ ___ ___ ___
Тип/розширення файлу: ____
Перейменуйте файл, додавши правильне розширення, та відкрийте його. Опишіть його.________________________
Чи отримали ви якусь інформацію, яка може бути корисною для цього розслідування?
_____________________________________________________________

Лабораторна 8. Аналіз метаданих файлів
[bookmark: _Hlk199943849]Відкрийте FTK Imager 
Відкрийте підозрілий образ (Vader_Home_Computer.001) у FTK imager.
Перейдіть до папки C:\Users\Owner\Documents\Business\Next Bombing Targets.
Експортуйте папку Next Bombing Targets на свій локальний комп'ютер.
Використайте ExifReader (https://www.exifreader.com/), щоб відкрити target1.jpg.
[image: ]
Перегляньте метадані, отримані з target1.jpg, та дайте відповіді на наступні питання.
Яка марка та модель камери, якою було зроблено фотографію?
_________________________
Яка дата та час зйомки фотографії?
_________________________
Які координати точки (широта та довгота) фотографії?
____________________________
Перейдіть до Карт Google та введіть точки широти та довготи.
(Пам’ятайте: N = додатна, S = від’ємна, E = додатна, W = від’ємна). [image: ]
Де саме знаходиться перша ціль теракту?
__________________________________
Використайте ExifReader, щоб відкрити Target2.jpg.
Перегляньте метадані, отримані з Target2.jpg, і дайте відповідь на наступні питання.
Яка марка та модель камери, якою було зроблено фотографію?
_________________________
Яка дата та час зйомки фотографії?
_________________________
Які координати точки (широта та довгота) фотографії?
____________________________
Перейдіть до Карт Google та введіть точки широти та довготи.
(Пам’ятайте: N = додатна, S = від’ємна, E = додатна, W = від’ємна). 
Де саме знаходиться друга ціль теракту?
__________________________________
Відкрийте Autopsy.
Відкрийте справу, що ви завели у попередніх лабораторних – Open Recent Case
[image: ]
Logical Files
[image: ]
Add > вкажіть шлях до збереженої папки Next Bombing Targets
[image: ]
Виберіть тільки Picture Analyzes
[image: ]
Analysis Results > EXIF Metadata
[image: ]
Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки?
_____________

Лабораторна 9. Аналіз журналу подій
Відкрийте FTK Imager 
Відкрийте підозрілий образ (Vader_Home_Computer.001) у FTK imager.
Перейдіть до папки \Windows\System32\Winevt\Logs. 
Експортуйте три журнали подій (Application.evtx Security.evtx System.evtx) на ваш комп’ютер.
Відкрийте Перегляд подій (Event Viewer) на вашому комп'ютері.
[image: ]
У меню оберіть Дія > Open Saved Log 
Виберіть експортовані файли .evtx.
[image: ]
Перегляньте журнал Security.
Event ID 4720 – створення облікового запису.
Скористайтеся фільтром Дія > Filter Current Log 
[image: ]
Знайдіть повідомлення журналу, де New Account: Account Name: Owner
[image: ]
Коли було створено профіль користувача Owner? 
___________________________________________
Коли було створено профіль користувача Tiny_Tim?
___________________________________________
Для скидання фільтру Дія > Clear Filter.
Event ID 4624 – вхід до облікового запису.
Скористайтеся фільтром Дія > Filter Current Log
Потім Скористайтеся пошуком Дія > Find 
[image: ]
Коли Owner входив до свого акаунту востаннє?
__________________________________________
Що означає Logon Type: 2?
___________________________________________
Коли Tiny_Tim входив до свого акаунту востаннє?
__________________________________________

Лабораторна 10. Аналіз реєстру
Відкрийте FTK Imager 
Змонтуйте підозріле зображення File > Image Mounting > Vader_Home_Computer.001
Встановіть та відкрийте Registry Explorer (https://ericzimmerman.github.io/)
Можливо під час встановлення потрібно буде завантажити та довстановити .NET
Registry Explorer потрібно запускати від імені Адміністратора (в контекстному меню – Запустити з правами адміністратора)!
[bookmark: _Hlk199950829]File > Load hive > F:\Windows\System32\config\SYSTEM
[image: ]
Відкрити.
[image: ]
**Це вікно повідомлення в Registry Explorer означає, що завантажений hive-файл (SYSTEM) є "брудним" (dirty) – тобто, містить незастосовані транзакції, які зберігаються у журнал-файлах (transaction logs). Це вказує на те, що файл реєстру був не повністю записаний перед вимкненням системи — тобто система не завершила роботу коректно. Це питання: чи хочете ви застосувати журнали транзакцій (.LOG1, .LOG2), щоб відновити найактуальніший стан реєстру.
Натискаємо Yes.
[image: ]
OK
У наступному діалозі позначте всі запропоновані LOG-файли:
SYSTEM.LOG1
SYSTEM.LOG2
(Ctrl + ліва кнопка миші)
[image: ]
Відкрити.
[image: ]
OK
[image: ]
Зберегти.
[image: ]
Yes
[image: ]
Yes
[image: ]
Перейдіть у вкладку Available bookmarks
F:\Windows\System32\config\SYSTEM
[image: ]
USBSTOR
[image: ]
Які флеш-накопичувачі (Device Name) були підключені до цієї системи?
__________________________
Які серійні номери пристроїв (Serial Number)?
__________________________
Коли відбувалося останнє підключення цих накопичувачів до системи?
__________________________
File > Load hive > F:\Users\Owner\NTUSER.DAT
[image: ]
Далі по аналогії з попереднім процесом.
[image: ]
F:\Users\Owner\NTUSER.DAT
[image: ]
RecentDocs
[image: ]
.txt
[image: ]
[bookmark: _Hlk200021159]Які файли .txt відкривалися в цій системі?
______________________________________
Які файли .zip відкривалися в цій системі?
______________________________________

Відкрийте Autopsy.
Відкрийте справу, що ви відкрили у попередніх лабораторних – Open Recent Case
Перейдіть Data Artifacts > USB Dtvice Attaches
[image: ]
Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки стосовно флеш-накопичувачів?
_____________

Лабораторна 11. Аналіз оперативної пам’яті
Завантажте архів дампу оперативної пам’яті VaderRAM.zip (https://drive.google.com/file/d/1OJ8G5Majx2AMJ3I80V86-6v_9EI9pbCm). Розархівуйте його.
Завантажте Volatility Workbench V3.0.1012 (16,4 МБ)
(https://www.osforensics.com/tools/volatility-workbench.html)
Запустити VolatilityWorkbench.exe
Image file: > Browse Image > Вибрати файл дампу VaderRAM.dmp
Platform: Windows
[image: ]
Кнопка Get Process List
Який час запису дампу пам’яті?
________________________________
Command: windows.info
Яка версія Windows?
________________________________
Command: windows.pslist
Чи запущений був під час дампу браузер?
__________________________________
Які PID цього процесу?
__________________________________
Чи підтримувалася під час запису дампу сесія у браузері (SessionId=1)?
__________________________________
Command: windows.netscan.NetScan
До яких ІРv4-адрес зверталася система по порту 80? Що це за процес?
________________________________________
Впишіть усі IP-адреси, до яких було встановлено підключення на момент запису дампу (State=ESTEBLISHED).
________________________________________
Перевірте їх через https://who.is/
Чи існувало підключення до Google?
_________________________________________
Command: windows.hashdump
Які хеші користувача Owner?
__________________________________________
За допомогою HxD Hex Editor відкрийте файл дампу пам’яті VaderRAM.dmp
За допомогою пошук знайдіть Password.txt
Яке значення паролю (між Password.txt та PK)?
____________________________________________
Відкрийте програму FTK Imager.
Змонтуйте підозріле зображення File > Image Mounting > Vader_Home_Computer.001
Перейдіть до папки C:\Users\Owner\Documents\
Знайдіть архів, для розпаковки якого потрібний пароль.
Спробуйте знайдений пароль.
Які серійні номери підроблених світлових мечів?
________________________________________

Лабораторна 12. Аналіз мобільного телефона
Завантажте архів пам’яті мобільного телефона Vader_Phone.zip (https://drive.google.com/file/d/19XgxWGRa1Ez9e-gQrAwM7VCONojRSLAH).
Розархівуйте його.
Відкрийте Autopsy.
Відкрийте справу, що ви завели у попередніх лабораторних – Open Recent Case
Logical Files
[image: ]
Add > вкажіть шлях до збереженої папки Vader_Phone
[image: ]
Виберіть:
· Android Analyzer (aLEAPP)
· Android Analyzer
[image: ]
Data Artifacts > Call Logs
[image: ]
Який номер абонента, з яким велося спілкування?
_____________
Data Artifacts > Contacts
[image: ]
Які контакти абонента?
_____________
Data Artifacts > Messages
[image: ]
Відновіть листування абонента?
_____________
Data Artifacts > Web Accounts
[image: ]
До якого акаунту підключений абонент?
_____________

[bookmark: _GoBack]Лабораторна 13. Аналіз інтернет-активності
Відкрийте програму FTK imager.
Додайте підозріле зображення (Vader_Home_Computer.001) до програми FTK imager.
File > Add Evidence Item > Image File та Далі > Browse та вибрати файл образу, вибрати Vader_Home_Computer.001 та відкрити > Finish.
Натисніть кнопки + для навігації по образу.
Перейдіть до кореневого каталогу Розділу 2 (root Partition 2).
Перейдіть до папки \Users\Owner\Downloads\
За потреби експортуйте деякі файли на ваш комп’ютер для перегляду.
Які файли можуть свідчити про злочинну діяльність?
__________________________________________
Що це за злочинна діяльність?
__________________________________________
Перейдіть до файлу \Users\Owner\AppData\Local\Google\Chrome\User Data\Default\Bookmarks
Проаналізуйте файл закладок.
Який URL закладки?
_________________________________________________
Перейдіть в вашому браузері за посиланням виявленої закладки.
Які докази ви знайшли?
_______________________________________________
Перейдіть до папки \Users\Owner\AppData\Local\Google\Chrome\User Data\Default\Cache\Cache_Data\
Подивиться файли кешу за 03.06.2025 13:26:33, 03.06.2025 13:30:17, 03.06.2025 13:31:29, 03.06.2025 13:31:33, 03.06.2025 13:31:34, 03.06.2025 13:31:45, 03.06.2025 13:31:53, 03.06.2025 13:32:11, 03.06.2025 13:32:56, 03.06.2025 13:32:57, 03.06.2025 13:33:05, 03.06.2025 13:33:06, 03.06.2025 13:33:07, 06.06.2025 09:07:22, 06.06.2025 09:08:37, 06.06.2025 09:33:14.
Які докази ви знайшли?
_______________________________________________
Перейдіть до файлу \Users\Owner\AppData\Local\Google\Chrome\User Data\Default\Network\Cookies
На якому сервісі був аккаунт у підозрюваного?
_______________________________________________
Змонтуйте підозріле зображення File > Image Mounting > Vader_Home_Computer.001
Встановіть / відкрийте BrowsingHistoryView від Nirsoft. (https://www.nirsoft.net/utils/browsing_history_view.html)
BrowsingHistoryView потрібно запускати від імені Адміністратора (в контекстному меню – Запустити з правами адміністратора)!
У полі Advanced Options зверніть увагу на поле Filter by visit date/time та виберіть Load History Items from any time.
Залиште позначеними всі веббраузери.
У розділі Load history from.. виберіть: Load history from the specified profile (For
example: c:\users\admin)
У наступному полі клацніть поле з трьома крапками, щоб відкрити навігаційний браузер Windows та перейдіть до змонтованого підозрілого зображення та папки \Users\Owner.
[image: ]
Натисніть OK.
Ви можете сортувати за будь-яким із заголовків. Ви також можете шукати терміни, натиснувши Edit > Find.
Які інтернет-браузери використовувався в цьому профілі?
_______________________________________________________
Знайдіть терміни search, google search, bing. Це дасть вам уявлення про те, які терміни підозрюваний шукав в Інтернеті. 
Які пошукові терміни шукав підозрюваний, які можуть бути цікавими для цього розслідування? Яку пошукову систему він використовував? Яка була дата/час?
_____________________________________________________________
Пошукайте по слову mail.
Чи мав користувач вебпошту? Яка була його адреса електронної пошти?
_____________________________________________________________
Знайдіть термін file:///. Це покаже файли, до яких було отримано доступ у локальній системі, але які були зареєстровані у файлі Index.dat. 
**ПРИМІТКА: %20 означає пробіл.
Чи є якісь файли, що стосуються цього розслідування?
________________________________________________________________
Чи знаходилися якісь із вищезгаданих відповідних файлів в іншому місці, ніж диск C:/ комп'ютера? Як вони називалися?
______________________________________________________________
Перед закриттям FTK Imager відмонтуйте всі змонтовані диски.
Відкрийте Autopsy.
Відкрийте справу, що ви завели у попередніх лабораторних – Open Recent Case
Перейдіть  Data Artifacts > Web Downloads
[image: ]
Через контекстне меню виберіть для знайдених файлів View Downloaded File in Directory, щоб подивитися їх. Повернення назад за допомогою стрілки у лівому верхньому куті.
[image: ]
Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки?
_____________
Перейдіть Data Artifacts > Web Bookmarks
[image: ]
Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки?
_____________
Перейдіть Data Artifacts > Chromium Profiles
[image: ]
Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки щодо адреси електронної пошти?
_____________
Перейдіть Data Artifacts > Web History
[image: ]
Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки?
_____________
Перейдіть Data Artifacts > Web Search
[image: ]
Чи підтверджуються раніше зроблені в цієї лабораторній роботі висновки?
_____________
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